You are viewing the v1 Nacelle Docs for existing merchants.New merchants can find the V2 docs here: nacelle.com/docs.

# Local Requirements

At a minimum, you will need to install Node, Git and an IDE on your local machine. Start by checking your version of Node by opening a command line window (terminal) and type:

node -v

The version should be v14.4 or greater. Please upgrade your version of Node if it is below v14.4.

Then make sure that your npm version is v7.0.0 or greater:

npm -v

Next, ensure Git is installed by typing:

git --version

Your Git version should be greater than 2.1. If your Git version does not exceed 2.1 please upgrade your version of Git.

Also, if you don't have a GitHub account now is a good time to create one.

While you're free to use whichever code editor you prefer, we highly recommend using VS Code.